When I try to download incubadoradeartistas.com, version 2.13.0 for the server and 2.12.0 because that the browser is installed. I view a warning in the console about version mismatch. Installation to be performed follow to the indict https://docs.incubadoradeartistas.com.io/en/2.13.0/deployment/deploying-on-premises/ ( curl https://s3-eu-west-1.amazonaws.com/aws.incubadoradeartistas.com.io/install_incubadoradeartistas.com_2.13.0.sh | bash )

I try to start the broadcast from the webcam, but I get link errors via sockets.

You are watching: Error during websocket handshake: unexpected response code: 400

WebSocket link to ‘wss://my_domain/incubadoradeartistas.com’ failed: Error throughout WebSocket handshake: Unexpected response code: 400

How have the right to I fix this error?


*

*

Thanks for the answer.

I don’t understand just how to install version 2.13.0 for the internet browser in Docker.All ns did was install incubadoradeartistas.com via curl v version 2.13.0 (curl https://s3-eu-west-1.amazonaws.com/aws.incubadoradeartistas.com.io/install_incubadoradeartistas.com_2.13.0.sh | bash)After that, i configured the environment and also ran the command ./incubadoradeartistas.com start


Sorry, mine fault. Neglect version mismatch warning.

Please re-superstructure incubadoradeartistas.com logs through us therefore we can take a look.

Have you followed deployment instructions together explained? carry out you have some kind of turning back proxy configured? it seem there are a difficulty with WebSockets (maybe associated with reverse proxies). Space you making use of services like CloudFlare or similar?

Regards.


I did the installation action by action according come the instructions here - https://docs.incubadoradeartistas.com.io/en/2.13.0/deployment/deploying-on-premises/The installation was made on our own server

We have reverse proxy because that websockets by nginx

location /incubadoradeartistas.com ssi on; proxy_pass http://ip-address:5443; encompass proxy_params; proxy_http_version 1.1; proxy_set_header upgrade $http_upgrade; proxy_set_header link "Upgrade"; proxy_set_header host $host;

This is a link to logs:

https://drive.google.com/file/d/1sQOb0ktzazBQMi0DHIrAytN_DUdm4MLD/view?usp=sharing

For Redis change configuration in docker-compose to my own to change default port

in docker-compose.yml:

redis: build: ./redis restart: always network_mode: hold volumes: - ./redis/redis.conf:/usr/local/etc/redis/redis.conf

./redis/Dockerfile

FROM redis:5.0.7COPY redis.conf /usr/local/etc/redis/redis.confCMD < "redis-server", "/usr/local/etc/redis/redis.conf" >

./redis/redis.conf

bind 0.0.0.0protected-mode yesport 6380tcp-backlog 511timeout 0tcp-keepalive 300#pidfile /var/run/redis/redis-server.pid#loglevel notice#logfile /data/log/redis-server.logdatabases 16always-show-logo yessave 900 1save 300 10save 60 10000stop-writes-on-bgsave-error yesrdbcompression yesrdbchecksum yes#dbfilename dump.rdb#dir /data/basesslave-serve-stale-data yesslave-read-only yesrepl-diskless-sync norepl-diskless-sync-delay 5repl-disable-tcp-nodelay noslave-priority 100lazyfree-lazy-eviction nolazyfree-lazy-expire nolazyfree-lazy-server-del noslave-lazy-flush noappendonly yesappendfilename "appendonly.aof"appendfsync everysecno-appendfsync-on-rewrite noauto-aof-rewrite-percentage 100auto-aof-rewrite-min-size 64mbaof-load-truncated yesaof-use-rdb-preamble nolua-time-limit 5000slowlog-log-slower-than 10000slowlog-max-len 128latency-monitor-threshold 0notify-keyspace-events ""hash-max-ziplist-entries 512hash-max-ziplist-value 64list-max-ziplist-size -2list-compress-depth 0set-max-intset-entries 512zset-max-ziplist-entries 128zset-max-ziplist-value 64hll-sparse-max-bytes 3000activerehashing yesclient-output-buffer-limit normal 0 0 0client-output-buffer-limit servant 256mb 64mb 60client-output-buffer-limit pubsub 32mb 8mb 60hz 10aof-rewrite-incremental-fsync yesThat’s all ns changed


Can girlfriend test through a clean surroundings without any customization please?

To recognize if some of your alters caused the issue.


I make the efforts to install it without any type of changes. The trouble remains the same.

See more: The Expanse Season 3 Episode 11 Review: Fallen World, The Expanse Fallen World (Tv Episode 2018)

There might be difficulties with the ports, but all the ports from the documentation description have been opened.


We can not see the logs. Have you fastened them?

Can you show nginx and also incubadoradeartistas.com server logs please?

Regards


nginx

example.comnginx_1 | Proxy mode: CEnginx_1 | Demos mode: truenginx_1 | ===Mode owncert===nginx_1 | making use of owmcert…nginx_1 | Restarting nginx: nginx.nginx_1 | 192.168.0.26 - incubadoradeartistas.comAPP <11/May/2020:06:05:29 +0000> “POST /api/sessions HTTP/1.0” 200 39 “https://domain.ru/” “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, prefer Gecko) Chrome/81.0.4044.138 Safari/537.36” “94.25.239.21”nginx_1 | 192.168.0.26 - incubadoradeartistas.comAPP <11/May/2020:06:05:30 +0000> “POST /api/tokens HTTP/1.0” 200 406 “https://domain.ru/” “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, choose Gecko) Chrome/81.0.4044.138 Safari/537.36” “94.25.239.21”nginx_1 | 192.168.0.26 - - <11/May/2020:06:05:30 +0000> “GET /incubadoradeartistas.com HTTP/1.0” 400 34 “-” “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, favor Gecko) Chrome/81.0.4044.138 Safari/537.36” “94.25.239.21”nginx_1 | 192.168.0.26 - - <11/May/2020:06:05:30 +0000> “GET /incubadoradeartistas.com HTTP/1.0” 400 34 “-” “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, prefer Gecko) Chrome/81.0.4044.138 Safari/537.36” “94.25.239.21”nginx_1 | 192.168.0.26 - - <11/May/2020:06:05:34 +0000> “GET /incubadoradeartistas.com HTTP/1.0” 400 34 “-” “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, prefer Gecko) Chrome/81.0.4044.138 Safari/537.36” “94.25.239.21”nginx_1 | 192.168.0.26 - - <11/May/2020:06:05:37 +0000> “GET /incubadoradeartistas.com HTTP/1.0” 400 34 “-” “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, prefer Gecko) Chrome/81.0.4044.138 Safari/537.36” “94.25.239.21”


micael.gallego may 13, 2020, 10:22am #11

We have actually improved numerous installation details in 2.14 version. Can you test v it?


matkonstant may 14, 2020, 8:58am #12

We resolved the problem with sockets for version 2.13 by configuring nginx

server ... Location / proxy_pass https://our_ip_address; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; proxy_set_header X-Forwarded-Proto $scheme; proxy_set_header hold $http_host; ar /incubadoradeartistas.com proxy_pass https://our_ip_address; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; proxy_set_header X-Forwarded-Proto $scheme; proxy_set_header host $host; proxy_http_version 1.1; proxy_set_header upgrade $http_upgrade; proxy_set_header connection "Upgrade"; ...